collegamento a DataBase 3CX v11

anonymous

Well-Known Member
Registrato
14 Gennaio 2008
Messaggi
19.170
Buongiorno,

sto utilizzando 3CX v 11 e ho necessità di collegarmi al DB PostgreSql per integrare una applicazione. Il server è un sistema operativo WIn7 64bit, firewall abbassato, uac al minimo. Nessun antivirus installato.

Ho letto vari post nei forum 3CX e ho implementato le seguenti modifiche da C:Program Files3CX PhoneSystemDataDB

FILE pg_hba.conf

# TYPE DATABASE USER CIDR-ADDRESS METHOD

# IPv4 local connections:
host all all 127.0.0.1/32 password
host all logsreader 0.0.0.0/32 password

# IPv6 local connections:
host all all ::1/128 password

FILE posgresql.conf

listen_addresses = '*'

a questo punto il DB dovrebbe essere in ascolto sulla porta 5480 e accessibile da tutti i client. Tuttavia con pg Admin se micollego da un pc nella lan ottengo un messaggio

"Access to Database Denied"

indicandomi che non esiste una entry valida nel file pg_ba.conf .

Se mi collego con pgadmin su localhost invece ho un errore di autenticazione.

Ho guardato anche il file pg_auth e ho trovato 3 utenti
"logsreader" "md5xxx" ""
"phoneadmin" "" ""
"phonesystem" "md5xxx" ""

tra cui il logsreader menzionato nelle guide per connettersi al db. Vedo però che la password è in md5 mentre nel pg_hba.conf ho inserito una codifica password "password", sempre seguendo le guide sui forum 3CX.

http://apetec.com/voip/3CX-RemoteDB.htm

La connessione che effettuo è sulla porta 5480 (controllata in postgresql.conf) e ssl Disable .

Sapete darmi indicazioni ulteriori?

Grazie
 
RISOLTO:

le informazioni di autenticazione per postreSql sono in C:/Program Files/3CX PhoneSystem/Bin/3CXPhoneSystem.ini dove sono indicati i due utenti, uno di amministrazione e uno user generico. Con pgAdmin da localhost (3CX server) riesco a stabilire una connessione con il dataBase.

Per le connessione dalla LAN invece ho notato che nel file pg_hba.conf bisogna indicare l' ip esatto del client che si va a connettere al database. Infatti indicando 10.0.0.0/24 per tutta una classe ip, mi viene restituito un errore di connessione per il file pg_hba.conf, invece indicando l' ip del client (eg. 10.0.0.22/24 creo una regola specifica) riesco a connettermi correttamente al dataBase con tutti gli utenti.

In effetti questa è una regola più corretta perchè restringe il campo dei client che si connettono al database all' insieme di effettivi utilizzatori.
 

Inizia con 3CX – Admin

Forum statistics

Discussioni
44.659
Messaggi
233.415
Membri
78.445
Ultimo Iscritto
NordNico