FQDN 3CX Certificato SSL scaduto

fidokasrl

Silver Partner
Registrato
10 Febbraio 2021
Messaggi
29
Salve a tutti,
mi accorgo oggi di non poter accedere al mio pbx da chrome e app ios per un errore di certificato scaduto. Firefox su pc mi permette l'accesso, così come l'app su android.
La dashboard non presenta errori.
Un controllo del certificato SSL su https://www.sslshopper.com/ssl-checker.html indica che è scaduto da due giorni.
C'è un comando da shell per forzare il rinnovo del SSL, oppure avviene automaticamente e non mi resta che...attendere :p?
Grazie
 
Ciao,
in teoria, quando hai un centralino con licenza valida, versione aggiornata e connessione internet, il rinnovo avviene automaticamente prima della scadenza, quindi in questo caso è mancata una di queste condizioni.
Se il problema è stata la mancanza di connessione puoi forzare manualmente il rinnovo (di seguito la procedura), altrimenti, se la licenza è scaduta o la versione non è aggiornata, devi per forza aggiornare il centralino.

To force the update:
  1. Go in Advanced / Parameters:

    Set or Add TEMPORARY_SELF_SIGNED_CERTIFICATE_GENERATED and give it value of 1

    • Linux:
      - Log in via SSH.
      - su phonesystem
      - /usr/lib/3cxpbx/PbxConfigTool -renew-certificates
      • Windows:
        - On the 3CX Server open CMD.
        - Type in the command: "C:\Program Files\3CX Phone System\Bin\PbxConfigTool.exe" -renew-certificates
  2. Press Enter and the result should look something like this:
    blob1476428313029.png
 
La licenza è in corso di validità, la versione è aggiornata alla v 20.0.4.487
Ho seguito i punti, ma purtroppo ricevo il seguente errore tramite mail di notifica:

Il rinnovo del certificato SSL per xxx.my3cx.it non è andato a buon fine - Error:
IpUpdater.FqdnGenerationException: Error creating FQDN: FQDN generation for this key is in progress. Please try later.
at PostInstall.CertificateGenerator.ProcessCertificatesDirectory(String directory, Boolean temporaryCertificateGenerated, Int32 regenerateNotSelfSignedCertificatesFrom, Int32 regenerateNotSelfSignedCertificatesTo, PhoneSystem ps, Int32 regenerateCertificateExiredInDays, UInt16 sipPort, UInt16 tunnelPort, Nullable`1 httpPort, Nullable`1 httpsPort, Boolean isPassiveFailoverMode, Boolean enableDnsHelper)
at PostInstall.CertificateGenerator.RenewCertificates(String appBin, String appData)

A communication error occurred between the DNS Servers and LetsEncrypt. This rarely happens and is usually resolved on the second attempt. 3CX will try again.
 
Let's Encrypt h avuto un problema ieri, che ora pare risolto
Riprova stamattina
 
  • Like
Reactions: fidokasrl
Buongiorno,
ho avuto negli ultimi giorni lo stesso problema di SSL scaduto causa prolungata mancanza di connessione del PC che ospita 3CX on premise.

Ho applicato C:\Program Files\3CX Phone System\Bin\PbxConfigTool.exe" -renew-certificates ma senza successo.
Ho fatto anche il refresh della licenza ma niente da fare.
Se provo a aggiungere un account nell'app 3CX con il qrcode mi dice "errore SSL impossibile effettuare una connessione sicura con il server"

Anche l'interno 200 risulta non approvvigionato
Grazie della cortese attenzione

Giampaolo Pirrera
 
prima di lanciare il comando, hai impostato il parametro?

TEMPORARY_SELF_SIGNED_CERTIFICATE_GENERATED and give it value of 1
 
ho impostato il parametro TEMPORARY_SELF_SIGNED_CERTIFICATE_GENERATED a 1

lanciando il comando da prompt del dos rimane li' senza ridarmi il prompt disponibile.

Pero' ora aggiungendo l'account dall'APP del telefono non da' piu' l'errore SSL e entrando in console con firefox non mi da' piu' l'errore di prima del sito non sicuro

Pero' rimane il problema dell'interno 200 non approvvigionato anche se poi chiamando il numero lui funziona regolarmente e si sente correttamente.. Devo disinstallare il telefono resettandolo e rifare l'assegnazione all'interno 200 ?
 

Allegati

  • Screenshot 2025-08-27 172635.png
    Screenshot 2025-08-27 172635.png
    59,7 KB · Visite: 3
  • Screenshot 2025-08-27 173426.png
    Screenshot 2025-08-27 173426.png
    30,5 KB · Visite: 2
  • Screenshot 2025-08-27 175214.png
    Screenshot 2025-08-27 175214.png
    5,5 KB · Visite: 2
Ultima modifica:
se non vedi più l'errore, mi sa che il certificato si è rinnovato.
Cliccando sul "lucchetto" in testa alla barra degli indirizzi di firefox dovresti vedere le informazoni sul certificato e la relativa scadenza

Per quanto riguarda l'interno 200, dalla schermata utenti vedo un telefono YL T22, mentre quello connesso è un T23
Quale telefono sta usando?
Hai impostato il T23 senza eliminare il T22?
 
Buongiorno Marcello.
il certificato e' a posto, scade a novembre.

Il telefono 200 e' li' da ANNI, mai sostituito e mai avuto segnalazioni di UNPROVVISIONED
E' l'unico telefono fisso presente ed e' li' dallla v18 almeno se non prima.
Se provo a entrare nella sua console web con firefox mi dice:

https://xxx.xxx.xxx.xxxx/servlet?p=login&q=loginForm&jumpto=status ha restituito un header con caratteri vuoti. Questo non è consentito in base agli standard di sicurezza web.

se invece entro con Chrome la pagina si apre correttamente.Ribadisco che le telefonate arrivano, il telefono suona e si sente tutto.

L'interno e' il 200. Posso resettare il telefono e farlo riapprovvigionare sempre sul 200 controllando che lo faccia per un T23G ?

Saluti
 
sì, resettalo e riassegnalo
 
Ok, resettato, approvvigionato e riassegnato correttamente come T23G
Grazie dell'assistenza
Saluti
 
@MarcelloL_3CX io ho impostato TEMPORARY_SELF_SIGNED_CERTIFICATE_GENERATED and give it value of 1 e in ssh ho lanciato il comando, ma ottengo

root@3cx:~# /usr/lib/3cxpbx/PbxConfigTool -renew-certificates
3cxpbx.sync is locked
 
Tutto ok si è aggiornato durante la notte
 
Buongiorno @MarcelloL_3CX , ho un problema di configurazione, ho aggiornato il centralino 3cx alla versione 20 dalla 18 precedente e importato la configurazione di backup. Fino a qui nessun problema il centralino funziona correttamente; ma sto avendo problemi di configurazion e funzionamento dell'app 3cx scaricata dal microsoft store. Al momento dell'inserimento dell URL 3cx (che raggiungo via web) mi dice host sconosciuto; mi sono accorto che accedendo al pannello admin via web in alto il certificato del sito risulta essere scaduto, come posso fare per rinnovare? la procedura di aggiornamento forzato diciamo cosi tramite cmd l ho eseguita ma non è cambiato nulla..
Attendo un riscontro in merito
Grazie Mille
 
la procedura per il rinnovo forzato è quella indicata, ricordandosi di impostare il parametro a 1
Hai riavviato i servizi del centralino, dopo il rinnovo?
Se fai su
Sistema > Licenza e forzi il refresh della licenza, vedi errori?
 
Allora,
ora che ho fatto il refresh come indicato mi ha dato questo erorre: "1758881795600.pngprima invece non me lo dava.

Dopo aver rieseguito login ora è nuovamente questa sezione ma cmq il certificato risulta scaduto 1758881994228.png
 
il centralino non sembra comunicare con l'esterno
Il firewall check cosa dice?
 
In realta però io riesco ad aprire la pagina di gestione anche da locale su altro pc e da smartphone..probabilmente è tutto legato a quel certificato che nn riesce a rinnovare
 

Inizia con 3CX – Admin

Forum statistics

Discussioni
44.658
Messaggi
233.413
Membri
78.444
Ultimo Iscritto
PCCAdmin