NET::ERR_CERT_DATE_INVALID

gptechnology

Customer
Registrato
2 Luglio 2019
Messaggi
46
Buongiorno, all'apertura della pagina web del client mi restituisce l'errore NET::ERR_CERT_DATE_INVALID , la licenza è attiva
come posso risolvere ?
 
ciao,
hai il certificato SSL del tuo dominio scaduto
che versioone hai del centralino?
 
l'ultima versione la 16 aggiornata,
 
e hai usato un dominio 3CX?
se sì, prova la procedura di seguito

Per forzare il rinnovo vedi di seguito:

To force the update:

Dashboard > Settings > Parameters
Set or Add TEMPORARY_SELF_SIGNED_CERTIFICATE_GENERATED and give it value of 1

    • Windows:
      - On the 3CX Server open CMD.
      - Type in the command: "C:\Program Files\3CX Phone System\Bin\PBXWizard\PbxConfigTool.exe" -renew-certificates
    • Linux:
      - Log in via SSH.
      - Type: /usr/lib/3cxpbx/PbxConfigTool -renew-certificates
  1. Press Enter and the result should look something like this:

    blob1476428313029.png

Restart nginx just to be sure and the certificate should have been renewed.
For Linux, to restart nginx type: service nginx restart

You can check the C:\ProgramData\3CX\Data\Logs\PbxConfigTool.log to see log of the action
 
Grazie per la risposta, risolto!!!!
 
Ho lo stesso problema, ma facendo la procedura non rinnova il certificato:
2020/05/22 18:23:52.908|Dbg|0001| Connecting to PhoneSystem
2020/05/22 18:23:54.272|Dbg|0001| PhoneSystemConnected = True (waittime=00:00:01.3640995)
2020/05/22 18:23:54.272|Dbg|0001| PhoneSystemConnected(2) = True
2020/05/22 18:23:54.275|Dbg|0001| Parameter name: REGENERATE_CERTIFICATE_EXPIRED_IN_DAYS, value = 25
2020/05/22 18:23:54.275|Dbg|0001| Is temporary certificate generated = False
2020/05/22 18:23:54.275|Dbg|0001| regenerateFromStr = , regenerateToStr =
2020/05/22 18:23:54.275|Dbg|0001| SIPPORT port in PBX = 5060
2020/05/22 18:23:54.275|Dbg|0001| Using SipPort = 5060
2020/05/22 18:23:54.275|Dbg|0001| TNL_CLIENT_LISTEN_PORT port in PBX = 5090
2020/05/22 18:23:54.275|Dbg|0001| Using TunnelPort = 5090
2020/05/22 18:23:54.316|Dbg|0001| Processing directory = C:\Program Files\3CX Phone System\Bin\nginx\conf\instance1, regenerateCertificateExiredInDays = 25, temporaryCertificateGenerated = False, regenerateNotSelfSignedCertificatesFrom = 0, regenerateNotSelfSignedCertificatesTo = 7, isPassiveFailoverMode = False
2020/05/22 18:23:54.316|Dbg|0001| Real (not self-signed) certificates regenerates from 0 to 7 hour. Skip.
2020/05/22 18:23:54.316|Dbg|0001| Processing directory C:\Program Files\3CX Phone System\Bin\nginx\conf\instance1 completed
2020/05/22 18:23:54.316|Dbg|0001| Disconnecting from PhoneSystem
2020/05/22 18:23:56.697|Dbg|0001| Phone System disconnected
2020/05/22 18:23:56.697|Dbg|0001| Finish updating certificates. Updated 0 certificates



mail ricevuta:
HTTPS Certificate renewal Failed - Error:
System.UnauthorizedAccessException: Access to the path 'C:\Program Files\3CX Phone System\Bin\nginx\conf\instance1\dhparam.pem' is denied.
at System.IO.FileStream.ValidateFileHandle(SafeFileHandle fileHandle)
at System.IO.FileStream.CreateFileOpenHandle(FileMode mode, FileShare share, FileOptions options)
at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize, FileOptions options)
at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share)
at System.IO.File.InternalWriteAllBytes(String path, Byte[] bytes)
at System.IO.File.WriteAllBytes(String path, Byte[] bytes)
at PostInstall.CertificateHelper.SaveFile(String fullPath, Byte[] content, String comment)
at PostInstall.CertificateHelper.ProcessCertificatesDirectory(String directory, Boolean temporaryCertificateGenerated, Int32 regenerateNotSelfSignedCertificatesFrom, Int32 regenerateNotSelfSignedCertificatesTo, CloudServerStatus statuses, Int32 regenerateCertificateExiredInDays, String appBin, UInt16 sipPort, UInt16 tunnelPort, Boolean isPassiveFailoverMode)
at PostInstall.CertificateHelper.RenewCertificates(String appBin, String nginxConfigFolder, String configurationPath)
 
Ultima modifica:
ho risolto disinstallando e reinstallando
 
A me succede regolarmente ogni tre mesi, e lo devo rigenerare ogni volta manualmente.
Potrebbe essere perchè spengo il centralino di notte ?
Non è che la procedura di rinnovo automatico del certificato gira in orario notturno ?
 
Ciao Alessandro,
è sicuramente per quello.
La costante possibilità di accesso da parte del centralino ai server 3cx è un requisito (è un server a tutti gi effetti).
Lascia acceso il centralino e non avrai più errori.
 

Inizia con 3CX – Admin

Forum statistics

Discussioni
44.659
Messaggi
233.416
Membri
78.446
Ultimo Iscritto
Ibra_siby