POSTGRES - could not fsync segment

anonymous

Well-Known Member
Registrato
14 Gennaio 2008
Messaggi
19.170
Ciao.

A seguito di un riavvio amministrativo ho il servizio DB che parte ma si arresta.

Nel log trovo :

LOG: database system shutdown was interrupted; last known up at 2014-08-20 15:41:34 CEST
LOG: database system was not properly shut down; automatic recovery in progress
LOG: redo starts at 3/84352B60
LOG: record with zero length at 3/A0F4F8A8
LOG: redo done at 3/A0F4F878
LOG: last completed transaction was at log time 2014-08-20 14:19:09.937+02
FATAL: could not fsync segment 0 of relation 1663/16385/17333: Bad file descriptor
LOG: startup process (PID 5244) exited with exit code 1
LOG: aborting startup due to startup process failure

Ho fatto manualmente ripartire il DB ma 3CX non lo riconosce e non mi permette neanche di fare il restore di un backup precedente in quanto non trova connessione al DB.

Qualcuno ha una soluzione per rimuovere i descrittori errati dal db ?
 
I believe your issue was investigated in a support ticket correct ?
database corruption and file rights issues here. Restoring your full backup on a new tenant fixed issue so I will lock this topic.
 

Inizia con 3CX – Admin

Forum statistics

Discussioni
44.659
Messaggi
233.415
Membri
78.445
Ultimo Iscritto
NordNico