Probela con Provide voIP

wicom

Registrato
21 Ottobre 2014
Messaggi
309
Ciao ragazzi

Ho installato la nuova versione di 3cx su un server 2003 ho un problemaq quando inserisco un provider VoIP, faccio la normale procedura inserisco il nome del porvide, metto generic VoIP Provide, poi metto il numero di telefono, l'IP del server SIP, lascio 5060 come porta, al prossimo template metto: numero esterno, id dell'accounto VoIP, password e 2 come chiamate simultanee, clicco sul tasto avanti e invece di ultimare la procedura come di solito avviene mi tira fuori il seguente mess di errore:

An exception occurred AccountDetail Error: Object reference not set to an instance of an object

Grazie
 
E' un 2003 standard o un sbs ?
 
Sembra che tu abbia un problema con IIS. SBS usa l'istanza di default per le routine interne e per il servizi intranet. Quindi dovresti controllare il profilo in IIS.
Considera che SBS non è l'ambiente più adatto per usare 3CX perchè dovresti anche provvedere a mettere delle esclusioni sulle porte da utilizzare in quanto sei in conflitto con le porte occupate dal server DNS e 3cx non ti funzionerò mai correttamente. In primis il test del firewall ti darà errori sul server stun ma il problema più grave è conflitto tra le porte RTP e il server DNS.
Mi è capitato diverse volte di installare 3CX su server SBS ed ogni volta ho ricontrato errori diversi ma quelli (sempre risolti) ma quelli che ti ho segnalato sono quelli che si verificano nel 99% dei casi.
Se hai delle buone basi sistemistiche dovresti riuscire ad identificare e risolvere i problemi perdendoci al massimo 2 o 3 ore. Altrimenti ti conviene installare 3CX in virtual machine (dove peraltro funziona benissimo) utilizzando virtual Server 2005. In questo secondo caso l'operatività risulta molto migiore ed anche la reattivitò del sistema. Al massimo devi aumentare la ram di sistema pensando di allocare almeno un paio di GB alla virtual machine con 3CX. Come SO puoi utilizzare un 2003 standard oppure un più economico XP.

Ciao
 
La cosa Mateo è che funzionava benissimo, di fatto su questa macchina è installato un programma di ristorazione della Lasersoft non so in che modo può andare in conflitto con il mio 3cx sta di fatto che quando su questo server mette mani il tecnico della lasersoft per fare manutanzione sul suo programma mi combina un casino e la cosa ancora + brutta è che non mi dice mai cosa ha fatto.
Cmq adesso vedo un pò se riesco a trovare dove sta l'inghippo almeno per poter configurare un provider VoIP esterno.

Saluti Max
 
Ciao,
a maggior ragione, se posso darti un consiglio, non tenere 3CX sul server SBS, dal momento che ci sono pure altri applicativi installati. Non so quanto tempo è che l'hai installato ma i problemi che ti ho riportato sono tutti documentati e riscontrati più di una volta. Sul Forum per i Partner ne abbiamo discusso in più di una occasione tanto è che 3CX non è certificato per funzionare su SBS.
 
Svelato il mistero matteo

In pratica a quanto pare SBS non centra nulla vengo e mi spiego:

Ho installato e configurato il centralino su SBS2003 ho impostato tramite wizard la normale configurazione di 3cx una volta avviato mi autentico ed inizio la config degli interni, ho impostato 9 interni, successivamente ho messo in piedi un gruppo suonerie dove ho incluso 3 interni per le chiamate in arrivo.
Successivamente a questo volevo impostare il provider VoIP per le chiamate in uscita, faccio tutto ma appena arrivo nella fase finale mi esce fuori quel messaggio di errore che ho postato prima.
Bene da li si può presupporre che sia un conflitto con altro software oppure SBS che funziona male insomma per tagliare la testa al toro che faccio prendo un altra macchina con Xp Pro reinstallo il centralino ex novo con l'ultima versione faccio la prima conf con il wizard e mi fermo.
Torno su SBS faccio un backup di quello che avevo configurato (anche se poco) e lo metto su una cartella condivisa in rete, poi ritorno sul PC con Xp Pro e faccio un restore della configurazione fatta su SBS, indovina un pò quando mi vado a configurare il provider VoIP stesso identico problema e stesso identico messaggio di errore.
A questo punto escludiamo SBS ed eventuali programmi installati.
Allora che faccio disinstallo 3cx lo reinstallo da capo e questa volta inizo proprio dalla config del provider VoIP e tutto va a buon fine, ultimata la config del Provider inizio quella degli interni, quindi di nuovo mi rimetto dentro i 9 interni e il gruppo suonerie, e fin quà tutto apposto, in quanto sia i 9 interni che il gruppo suonerie che funzionano bene .
A questo punto che faccio ritorno sui provider VoIP cerco di configurare un altro provider VoIP e indovina un pò???? stesso identico problema mi spunta lo stesso messaggio.
Quindi o sono gli interni che danno problemi o è il gruppo suoneria, non c'è altro.

Max
 
Ho risolto il problema, ho installato Explorer 7 e tutto si è sistemato evidentemente era un problema di Windows e non del centralino.

Grazie
 
Ciao,

io ho lo stesso problema, riesco a configurare tutto ma NON il provider voip.

Ho un pc dedicato con windows vista business edition ed internet explorer 7.

Qualche consiglio?

Grazie, Andrea Lando
 
Hai disattivato l'UAC in windows vista ?
Hai impostato il firewall correttamente ? Eventualmente a fine di test prova a disattivarlo completamente.
Hai qualche software antivirus con funzione di firewall o antipsy installato ?
 
UAC disabilitato
Firewall di vista disabilitato e pc riavviato.
Nessun antivirus

ma niente..... sono disperaaaaaaaaaaaaaaaaaaaaaato. Comunque grazie.
 
prova a postare la stampa schermo di come hai configurato il provider ? o non riesci proprio a configurarlo ?
 
Allora, passo tutti e tre gli step ovvero:
il primo (dal quale scelgo generic voip provider) e gli do un nome
il secondo, dove inserisco il server sip
il terzo, dove metto numero di telefono, password e chiamate simultanee.

Premendo il tasto per continuare mi appare quel tragico errore "object not set".... etc... etc.
 
Ti segnalo una patch che dovrebbe risolvere il tuo problema.
La puoi scaricare dal nostro sito web (http://www.eurylink.com) nell'area "Telefonia Voip" -> Downloads -> 3CX -> Patch V.7 -> PatchWebguiv7.zip
Non posso postarla qui per problemi di spazio.

Dovrebbe risolvere il tuo problema anche se in alcuni casi è necessario disinstallare completamente 3cx e applicarla successivamente.
Ad ogni modo prova a:
1) Stoppi tutti i servizi di 3CX
2) estrai il file Webguiinterface.dll e lo sovrascrivi nella cartella di installazione di 3CX Programmi3CXPhoneSystemDatahttpinterfacebin
3) Riavvii il PC

Il problema fino ad ora si verifica in maniera abbastanza random in alcune installazioni. A noi è capitato un errore simile ma nella parte di configurazione delle regole di inoltro sul provider. In ogni caso è un errore della GUI.

Fammi sapere se hai risolto.

Ciao
 
Grazie,

si lo avevo già fatto la setimana scorsa,comunque l'ho rifatto e non è cambiato nulla.
Sto seriamente valutando o il downgrade alla versione 6 o il passaggio ad asterisk.

Grazie molto per l'aiuto.
 
Se il problema ti permane dovresti fare una installazione pulita rimuovendo tutto e ripulendo il registro.
Se però hai la possibilità ti consiglio di installare la versione 7 su XP che, oltre ad essere più leggero, funziona decisamente meglio con 3CX. Il downgrade alla v.6 non credo che convenga molto poichè sarebbe una soluzione a metà. La fatica di reinstallare XP è comunque inferiore a quella di dedicare un pc appositamente ad asterisk. Senza considerare che i problemi con asterisk sono di gran lunga maggiori che quelli con 3CX.
Poi valuta tu ovviamente.

Ciao
 
ho seguito il tuo consiglio:

ho riformattato completamente il PC
Reinstallato Windows vista
Ora finalmente va tutto.
Se lo avessi immaginato prima non avrei perso tutto questo tempo.

Grazie x l'aiuto.
 
Di niente....a volte le soluzioni più estreme si rivelano quelle meno dispendiose in termini di tempo e di energia.

Ciao
 

Inizia con 3CX – Admin

Forum statistics

Discussioni
44.658
Messaggi
233.414
Membri
78.444
Ultimo Iscritto
PCCAdmin