Problema attivazione licenza

bygrp.com

Silver Partner
Registrato
23 Agosto 2019
Messaggi
443
Buongiorno a tutti sto installando 3cx linux on promise su un minipc tutto va a buon fine ma quando provo da interfaccia web
ad inserire la licenza mi da' questo errore Unable to connect with 3CX License server. Check your network and try again.
Ovviamente il minipc va in internet e come dns ho messo sia quelli di google che quelli di one.one ma non cambia nulla
ho riformattato il tutto ma niente da fare se provo al stessa installazione con la stessa configurazione su una macchina virtuale funziona perfettamente
Qualcuno ha qualche idea dove posso intervenire ?

Grazie a tutti Maisx
 
Ciao,
la VM e il miniPC sono nella stessa subnet? perchè questi sono tipicamente problemi di rete e/o di filtro sulla porta 443/protocollo https da parte di apparati in LAN
 
si si stessa identica rete ed ho usato lo stesso ip staccando il minipc
adesso magari provo ad installare la versione con debian 10 Grazie
 
Buongiorno a tutti sto installando 3cx linux on promise su un minipc tutto va a buon fine ma quando provo da interfaccia web
ad inserire la licenza mi da' questo errore Unable to connect with 3CX License server. Check your network and try again.
Ovviamente il minipc va in internet e come dns ho messo sia quelli di google che quelli di one.one ma non cambia nulla
ho riformattato il tutto ma niente da fare se provo al stessa installazione con la stessa configurazione su una macchina virtuale funziona perfettamente
Qualcuno ha qualche idea dove posso intervenire ?

Grazie a tutti Maisx
E' sicuramente un problema di rete.
Da console linux potresti capire cosa non va
Debian 10 è in versione Alpha, potrebbe non funzionare bene.
 
Ciao hai qualche consiglio di cosa potrei guardare dalla console di linux ? Grazie 1000
 
Da console, utente root, scrivi:

Codice:
ifconfig
e poi
Codice:
grep "nameserver" /etc/resolv.conf
e poi
Codice:
apt-cache policy 3cxpbx
 
i primi 2 li avevo controllati e sono apposto
sul terzo comando ottengo questo
Grazie 1000

root@3cx:~# apt-cache policy 3cxpbx
3cxpbx:
Installed: 16.0.8.9
Candidate: 16.0.8.9
Version table:
*** 16.0.8.9 500
500 http://downloads-global.3cx.com/downloads/debian stretch/main amd64 Packages
100 /var/lib/dpkg/status
16.0.7.1078 500
500 http://downloads-global.3cx.com/downloads/debian stretch/main amd64 Packages
16.0.6.655 500
500 http://downloads-global.3cx.com/downloads/debian stretch/main amd64 Packages
16.0.6.641 500
500 http://downloads-global.3cx.com/downloads/debian stretch/main amd64 Packages
16.0.5.622 500
500 http://downloads-global.3cx.com/downloads/debian stretch/main amd64 Packages
16.0.5.619 500
500 http://downloads-global.3cx.com/downloads/debian stretch/main amd64 Packages
16.0.5.612 500
500 http://downloads-global.3cx.com/downloads/debian stretch/main amd64 Packages
16.0.5.611 500
500 http://downloads-global.3cx.com/downloads/debian stretch/main amd64 Packages
16.0.4.504 500
500 http://downloads-global.3cx.com/downloads/debian stretch/main amd64 Packages
 
ti andrebbe di condividerli?

Eccoli

root@3cx:~# ifconfig
enp1s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet 192.168.2.239 netmask 255.255.255.0 broadcast 192.168.2.255
ether 00:0d:b9:5a:0c:e8 txqueuelen 1000 (Ethernet)
RX packets 117345 bytes 170886189 (162.9 MiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 59583 bytes 6826307 (6.5 MiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
device memory 0xf7a00000-f7a1ffff

lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
inet 127.0.0.1 netmask 255.0.0.0
loop txqueuelen 1 (Local Loopback)
RX packets 111 bytes 47785 (46.6 KiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 111 bytes 47785 (46.6 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0


root@3cx:~# grep "nameserver" /etc/resolv.conf
nameserver 8.8.8.8
 
Aggiungerei anche un secondo dns di riserva: 8.8.4.4
L'ip assegnato è statico? Hai editato il file?:
Codice:
nano /etc/network/interfaces

prova ora:
Codice:
ping activation.3cx.com
 
Avevo gia' guardato tutto comunque eccolo qua'
Grazie 1000 di tutto

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug enp1s0
iface enp1s0 inet static
address 192.168.2.239/24
gateway 192.168.2.1
# dns-* options are implemented by the resolvconf package, if installed
dns-nameservers 8.8.8.8
dns-search 3cx.local

root@3cx:~# ping activation.3cx.com
PING activation.3cx.com (151.80.125.88) 56(84) bytes of data.
 
Modificalo esattamente così:

Codice:
# The primary network interface
allow-hotplug enp1s0
iface enp1s0 inet static
address 192.168.2.239
netmask 255.255.255.0
gateway 192.168.2.1
dns-nameservers 8.8.8.8 8.8.4.4

e dopo:

Codice:
systemctl restart networking

Altri comandi per vedere se c'è qualche pacchetto non aggiornato:
Codice:
apt-get update
Codice:
apt-get upgrade
 
Oggi ho provato ad installare esattamente con la stessa procedura e gli stessi parametri
Debian 10 e poi 3cx ed è andato tutto liscio al primo colpo.
Grazie a tutti per l'aiuto
Maisx
 
ottimo.
Hai installato l'ultima versione Alpha5?
 
Adesso non ho piu' proseguito i test ma comunque ho installato prima debian 10 puro e poi da riga di commando 3CX Grazie
 

Inizia con 3CX – Admin

Forum statistics

Discussioni
44.659
Messaggi
233.416
Membri
78.446
Ultimo Iscritto
Ibra_siby