sbc unable to reach 3cx server

DeNino

Customer
Basic Certified
Registrato
19 Aprile 2021
Messaggi
8
Buonasera a tutti, ho un centralino su vm linux on premise, volevo configurare un SBC per una piccola sede remota nella quale ci saranno circa 5 interni.

Ho deciso di usare un raspberry pi4, ho fatto l'installazione regolarmente seguendo la guida, il problema sorge durante la configurazione con il server dove inserisco https://<FQDN CENTRALINO>:5001 e poi la authentication key id, continua a darmi l'errore "Unable to reach the 3CX Server at https://<FQDN CENTRALINO>:5001 Please double check "3CX Provisioning URL" value and confirm that the SBC Trunk is created properly from within your 3CX Management Console.

da quello che so non serve aprire porte sulla sede remota o sbaglio?

dai log del firewall che sta davanti al centralino, il traffico che arriva dall'ip pubblico della sede remota viene inoltrato al centralino con successo...


mi sto dimenticando di fare qualcosa?

grazie a tutti
ciao
 
Ciao,
l'SBC fa una connessione in uscita verso il centralino. Non devi aprire nessuna porta, lato sede remota, devi semplicemente consentire l'uscita verso Internet dell'SBC. Lato centralino, la porta tunnel è aperta sia TCP che UDP? e da un PC esterno alla rete del centralino, vedi e raggiungi la console 3CX senza problemi?
Infine: il centralino ha FQDN 3CX o proprietario?
 
Ciao Marcello, grazie per la velocissima risposta.

La porta tunnel 5090 è aperta sia TCP che UDP e appunto il firewall mi lascia passare il traffico

se digito l'indirizzo della console 3CX è raggiungibile da ovunque, ho impostato la restrizione degli ip quindi non rieco a fare il login da ovunque... devo togliere questa restrizione?

FQDN è propreietario e valido (rinnovato qualche settimana fa)

Posso provare il collegamento anche dalla lan del centralino o non funziona? giusto per comodità sennò devo spostarmi nell'altra sede..

grazie ciao
 
sembrerebbe tutto in regola, ma mi dici che il certificato è proprietario:
dall'esterno il browser lo apre senza warning di alcun tipo?
se scrivi il tuo FQDN quì, cosa ti dice il test?

 
Si dall'esterno lo apro senza nessun warning, l'ho testato ora su un pc esterno dal quale non avevo mai fatto l'accesso...

il test mi dice unable to connect to the server... ma il server ascolta sulla 5001, non sulla 443 percui mi sto regisatrando sul sito altrimenti non lo posso testare su un'altra porta.

Il certificato è una wildcard, ed eseguendo il test su un FQDM di un altro server che lo usa sulla 443 mi da rating A
 
sinceramente, ti consiglio di passare a FQDN 3CX, in questo modo questi problemi semplcemente scompaiono
 

Inizia con 3CX – Admin

Forum statistics

Discussioni
44.659
Messaggi
233.415
Membri
78.445
Ultimo Iscritto
NordNico