Aggiornamento V18 on premise fallisce

maurizio.zanetti

Silver Partner
Advanced Certified
Registrato
3 Febbraio 2021
Messaggi
32
Buongiorno.

Gestisco una ventina di centralini 3cx, di cui 3 sono on premise, mentre i restanti sono ospitati su varie piattaforme cloud (3cx, AWS).
Ho aggiornato senza problemi a V18 tutte le versioni cloud, mentre per quanto riguarda le versioni on premise l'aggiornamento fallisce. Tutte le versioni on premise sono linux installate con ISO 3cx ufficiali, gli errori che ricevo via mail sono sempre di questo tipo:

3CX attempted to update your 3CX Debian OS at XXXXXX.my3cx.it from Debian 9 to 10 and failed.
This may be caused by changes made to the OS after installation. The attached log file shows where the update failed.


Le macchine sono tutte "fisiche" (non VM) e nonostante il messaggio, non ho apportato modifiche al sistema.
Allego il file di log con gli errori, è sostanzialmente identico per tutte e 3.

Grazie.
 

Allegati

Ciao,
in casi simili ti segnalo questi articoli, ma in caso non riuscissi a risolvere, ti consiglio di fare un backup, nuova installazione pulita da ISO V18 e ripristino del tuo backup:


 
Grazie Marcello.

Darò un'occhiata agli articoli che mi hai segnalato, sperando di non doverli reinstallare.
Aggiorno il 3d appena ho notizie in merito.

Buona giornata.
 
Aggiornamento: entrambi i log di aggiornamento fallito hanno la riga
There seems to be an apt file lock in place.
L'errore rientra nel secondo link che mi hai girato: stasera riprovo ad eseguire l'aggiornamento almeno di un pbx, così da vedere se effettivamente si trattava solo di un problema temporaneo come indicato:
It is recommended that you try to upgrade the process again in 30 minutes. If the situation remains unchanged you can debug why APT or DPKG is locked or take the route to reinstall the system via backup and restore functionality onto a new Debian 10 instance. This also clears out any uncertainty if you are not sure how you had installed 3CX previously.
 
Banalmente ho riavviato il centralino prima di provare ad aggiornarlo e non si è ripresentato l'errore completando l'aggiornamento.
La cosa strana è che in seguito all'aggiornamento il MAC address risulta cambiato: il 3cx era configurato in DHCP con prenotazione e mi sono accorto che veniva assegnato un IP diverso dal precedente con un MAC address diverso, oltre che tecnicamente sbagliato (ebdfeb71000100012920402c3417ebdfeb71).
La stessa cosa era successa per il centralino che usiamo internamente: dopo l'aggiornamento il MAC è diventato (7e4817c00001000128ca499cd43d7e4817c0).
 
sei su macchina fisica o virtuale? e se virtuale, sei su HyperV?
 
Macchine fisiche: ho provato a sottoporre il problema anche sul forum internazionale e mi hanno risposto in questo modo, penso che sia utile saperlo per tutti.

Immagine 2021-11-12 111255.png
 
  • Like
Reactions: MarcelloL_3CX

Inizia con 3CX – Admin

Forum statistics

Discussioni
44.659
Messaggi
233.415
Membri
78.445
Ultimo Iscritto
NordNico