Collegamento Centralino/Centralino - UDP Diretto

anonymous

Well-Known Member
Registrato
14 Gennaio 2008
Messaggi
19.170
Salute a Tutti,
ho un problema, prima di effettuare cambio di tecnologia Fastweb da CVP a SHDSL avevamo due centralini collegati con il metodo UDP Diretto:
3CX Vers 9 Master e 3CX Vers 11 Slave e funzionavano perfettamente.
Ora con il cambio di Tecnologia di cui sopra è stato cambiato il router, pur mantenendo la stessa configurazione lo Slave non riesce più a registrarsi, Veramente per qualche istante lo ha fatto ma poi niente più.
E la cosa strana che il Master pur non registrato accetta ed effettua chiamate sullo Slave regolarmente .
C'è qualcuno che può aiutarmi ??

Ringrazio Anticipatamente
 
Premesso che le due reti siano su IP pubblico reale e non dietro NAT il problema può risiedere solo nella configurazione (NAT, Access List, SIP ALG) dei router o sulla tipologia dei router stessi. In ogni caso è sempre preferibile utilizzare un Bridge con Tunnel.
 
La ringrazio della risposta dott. Sala , ma volevo segnalarle meglio lo scenario:
in effetti il Master è su una nat e lo Slave nel Log ha le seguenti stringhe:

11-set-2013 11:42:28.484 [CM504007]: Next attempt to register Lc:10011(@Moretta Slave[]) is scheduled in 5 minute
11-set-2013 11:42:28.482 [CM504005]: Registration failed for: Lc:10011(@Moretta Slave[]); Cause: Cause: 403 Invalid password provided/REGISTER from 2.229.9.163:5060
11-set-2013 11:42:28.143 [CM504007]: Next attempt to register Lc:10000(@VoipVoice - IT[]) is scheduled in 5 minute
11-set-2013 11:42:28.140 [CM504005]: Registration failed for: Lc:10000(@VoipVoice - IT[]); Cause: Cause: 500 Registering glare condition/REGISTER from 109.238.17.166:5060
11-set-2013 11:42:28.015 [CM504003]: Sent registration request for Lc:10011(@Moretta Slave[])

Sembrerebbe un problema di Password, ma queste sono giuste.

Ho anche notato che chiudendo i servizi e riaprendoli Lo Slave si Collega ma dopo pochi secondi si riscollega.

Se ha dei suggerimenti .. oltre a quelli che mi ha già dato.

Grazie

Gaetano Cavallaro
 
E' con molta evidenza un problema dovuto a problemi di NAT e Router non configurati correttamente (lo si vede anche solo dall'errore di glare condition che compare relativamente ad uno dei provider registrati).
Vi sono diverse soluzioni applicabili ma non credo trattabili in questa sede in quanto piuttosto complesse e non strettamente riguardanti il 3CX stesso. La soluzione va dall'uso del tunnel alla configurazione corretta dei router mediante affiancamento di un router con IP dedicato (fra quelli del Pool) per il traffico Voip.
La soluzione, tranne casi molto particolari, esiste ma non è generica poichè richiede una verifica esatta delle singole configurazioni e degli apparati di networking.
 

Inizia con 3CX – Admin

Forum statistics

Discussioni
44.659
Messaggi
233.415
Membri
78.445
Ultimo Iscritto
NordNico