errore chiamate in uscita

Dante

Free User
Registrato
26 Dicembre 2021
Messaggi
24
Buongiorno
Ho installato il centralino 3CX, ho configurato il sip trunk, e la registrazione risulta corretta. Ricevo correttamente chiamate dall'esterno, ma quando provo a chiamare da un telefono interno verso numeri esterni da occupato e non invia la chiamata. Ho anche creato una regola in uscita con 0-9,+ ma niente da fare.

Dove ho sbagliato? e dove dovrei concentrarmi per risolvere il problema?
Premetto che il test del firewall è OK su tutte le porte.

Grazie e buona giornata
 
Controlla il registro errori e vedi quale errore ti da quando chiami.

Inizia da li
 
Call or Registration to xxxxxxxx@(Ln.10000@Generic SIP Trunk) has failed. 85.xx.xxx.xxx replied: 403 Forbidden; from IP:85.xx.xxx.xxx:5060
 
Provi a postare anche la regola di uscita che hai creato?
 
Risolto.
Nel Sip Trunk, nel pannello opzioni, ho attivato "Immettere IP Pubblico nell'Header SIP VIA", ed ho inserito l'ip pubblico della linea. adesso funziona tutto perfettamente.
 
Inoltre negli interni è importante eliminare il Caller ID in uscita, in modo che la chiamata prende quello impostato nel trunk
 
Purtroppo mi sono accorto che così facendo funzionano le chiamate in uscita ma non funzionano più quelle in entrata. c'è un modo per "Immettere IP Pubblico nell'Header SIP VIA" solo per le chiamate in uscita?
 
Secondo me non è li il problema....

Intanto, puoi scrivere con quale gestore voip stai lavorando?
 
con Fastweb

questo è il registro attività: Call to T:Line:10000>>"telefono da chiamare"@[Dev:sip:[email protected]] from L:2.1[Extn:101] failed, cause: Cause: 403 Forbidden/INVITE from 85.18.217.100:5060
 

Allegati

  • 1.jpg
    1.jpg
    1,1 MB · Visite: 16
  • 3.jpg
    3.jpg
    1,2 MB · Visite: 16
Sembra che il blocco sia lato fastweb.

Per la configurazione del SIP trunk hai seguito una guida trovata da qualche parte?

Ho ricercato Fastweb nel forum italiano e praticamente nessuno è riuscito a far funzionare le linee voip di Fastweb con 3cx se non utilizzando dei Gateway (ISDN o FXO).
 
ho lo stesso problema anche io, tutto è regolare la configurazione è perfetta il centralino passa tutti i test tutto verde le chiamate in ingresso funzionano alla perfezione ma in uscita lo stesso maledetto errore 403 Forbidden; from IP:85.18.217.100:5060

farò scrivere all'avvocato una pec pesante alla fastweb vediamo cosa succede... se qualcuno di voi ha trovat una soluzione per favore condividete la vostra esperienza.
 
Ciao non ho ancora capito se il problema dipende da Fastweb o da 3CX, un utente più esperto di me (Fracarza) mi ha comunicato quanto segue:

"Ho scoperto che 3CX non è compliant con RFC3261 (sezione 8.2.6.2):
The Via header field values in the response MUST equal the Via header field values in the request and MUST maintain the same ordering.

Quando si attiva l'opzione "Put Public IP in SIP VIA Header" viene riscritto l'header VIA nelle risposte e questo fa si che Fastweb si rifiuti di rispondere (quindi non funzionano le chiamate in entrata).
Se l'opzione non è attiva questo problema non accade, ma dall'altra parte nelle requests viene messo l'IP sbagliato, quello locale, e quindi Fastweb si rifiuta lo stesso di rispondere (quindi non funzionano le chiamate in uscita)."

Pertanto no so se la responsabilità è di fastweb oppure di 3CX.

Considera che comunque il voip fastweb funziona sia per le chiamate in uscita se imposti 3CX in un certo modo, e sia per le chiamate in entrata se lo imposti in un altro modo. Quindi fastewb credo ti risponderà che il problema non è suo. Dall'altro lato 3CX dice che fastweb non è un provider supportato e pertanto non credo ci sia soluzione al problema.
 
Vorrei ricordare che "Fastweb" non è un operatore voip certificato 3cx, quindi 3cx non ne garantisce il funzionamento.

Ho letto diversi forum di gente che ha provato a far funzionare la linea fastweb con 3cx, ma nessuno ha mai trovato una soluzione.

Saluti
 
Ciao Stormdrop
Per far funzionare 3CX perfettamente con fastweb basterebbe nelle opzioni del siptrunk suddividere in due l'opzione "Immettere IP Pubblico nell'Header SIP VIA", con l'opzione "Immettere IP Pubblico nell'Header SIP VIA per le chiamate in uscita" e "Immettere IP Pubblico nell'Header SIP VIA per le chiamate in entrata". così facendo abilitando solo l'opzione per le chiamate in uscita, il tutto funzionerebbe a meraviglia.

Lancio il suggerimento a 3CX e nello specifico a @marcello che potrebbe segnalare agli sviluppatori un possibile aggiornamento, che permetterebbe a 3CX di poter aprire il mercato agli oltre 2.000.000 di utenti fastweb.
 
Se guardate bene i trunk supportati sono operatori puramente voip, quindi 3cx la sua scelta l'ha fatta, sta ai tecnici che vogliono usare e proporre 3cx indirizzare i propri clienti verso operatori supportati.

Sinceramente condivido in pieno la scelta di 3cx nel preferire operatori che fanno voip da quando sono nati rispetto ai grandi operatori che hanno dovuto ripiegare sul voip.

Per fare un esempio qualche mese fa telecom ha avuto un grosso problema con il voip (ne hanno parlato in una discussione su questo forum) e ci sono voluti quasi 2 mesi perchè fosse risolto.
 
Anch'io ho lo stesso identico problema con Fastweb. Qualcuno ha trovato qualche soluzione ?
 

Inizia con 3CX – Admin

Forum statistics

Discussioni
44.659
Messaggi
233.415
Membri
78.445
Ultimo Iscritto
NordNico