FAILD TO RETRIVE THE PRECONFIGURATION FILE

  • Creatore Discussione Creatore Discussione ZIO
  • Data di Inizio Data di Inizio

ZIO

New User
Registrato
14 Aprile 2021
Messaggi
4
evidentemente però il server non lo raggiunge...
considera che quì sei a monte della completa installazione del centralino, se non riesci a scaricare quel file (che al contrario è accessibile) deve essere un problema del tuo ambiente
su che hypervisor sei?
 
evidentemente però il server non lo raggiunge...
considera che quì sei a monte della completa installazione del centralino, se non riesci a scaricare quel file (che al contrario è accessibile) deve essere un problema del tuo ambiente
su che hypervisor sei?
La vps è basata su Virtualizor KVM. Sono sicuro che non sia un problema di rete perché ho installato la iso normale e andava benissimo. Comunque ho seguito questa guida (https://www.3cx.com/community/threads/debian-install-fails-with-missing-file.62289/) e mi da questo errore durante l'installazione via WEB in uno degli ultimi passaggi:

System.Exception: Error in CreatingCloudServerManagementDatabase.sql: 42P04: database "masterprofiles" already exists ---> Npgsql.PostgresException: 42P04: database "masterprofiles" already exists at Npgsql.NpgsqlConnector.DoReadMessage(DataRowLoadingMode dataRowLoadingMode, Boolean isPrependedMessage) at
Npgsql.NpgsqlConnector.ReadMessageWithPrepended(DataRowLoadingMode dataRowLoadingMode) at Npgsql.NpgsqlDataReader.NextResultInternal() at Npgsql.NpgsqlDataReader.NextResult() at Npgsql.NpgsqlCommand.Execute(CommandBehavior behavior) at
Npgsql.NpgsqlCommand.ExecuteScalarInternal() at
PostInstall.DBConnection.ExecuteScriptInternal(NpgsqlConnection connection, String sqlQuery, IDictionary`2 parameters) at PostInstall.DBConnection.ExecuteScript(String sqlQuery, IDictionary`2 parameters) at _3CXCloudDBManager.DbConnectionExtensions.ExecuteScript(IDBConnection connection, Object configurationStructure, String scriptText, Boolean asResourceName) --- End of inner exception stack trace --- at
_3CXCloudDBManager.DbConnectionExtensions.ExecuteScript(IDBConnection connection, Object configurationStructure, String scriptText, Boolean asResourceName) at
_3CXCloudDBManager.CloudDBManager.CreateCloudServerManagementDatabase(IDBConnection superuser, CloudServerManagementDatabaseConfiguration configuration) at
PostInstall.SetupExecutor.CreateDatabase(Action`1 stateChanged) at
PostInstall.SetupExecutor.ExecuteSetup(SetupSettings setupSettings, Action`1 stateChanged) at PbxWebConfigTool.PbxSetupService.CreatePbxInternal(SetupSettings settings)

Il questo thread (https://www.3cx.com/community/threads/3cx-phone-system-installation-error.49072/) è riportato il mio problema e segnato come "solved" ma di solved non c'e' nulla. Il ragazzo dice esplicitamente "I don't know what happened but the error has been solved by itself". Tutti gli gli altri non sono riusciti a risolvere il problema.

Cordiali Saluti
 
non ho capito, cosa intendi con "usando la ISO normale" ?
come stai installando il centralino?
 
non ho capito, cosa intendi con "usando la ISO normale" ?
come stai installando il centralino?
Ho seguito due guide.
La prima è quella che mi fa caricare la iso che si scarica dal sito. Tuttavia questa procedura mi da il problema della connessione (esposto anche in questo thread: https://www.3cx.com/community/threads/debian-install-fails-with-missing-file.62289/)

Allora ho seguito un altra guida (proposta sempre qui https://www.3cx.com/community/threads/debian-install-fails-with-missing-file.62289/ ma anche sul sito ufficiale di 3CX:

sudo wget -O- http://downloads-global.3cx.com/downloads/3cxpbx/public.key | apt-key add -
(this will download the 3CX public key and add it to the apt keychain)

sudo echo "deb http://downloads-global.3cx.com/downloads/debian stretch main" | tee /etc/apt/sources.list.d/3cxpbx.list
(this will add the 3CX repository to the apt-update list)

sudo apt-get update
(searches for any updates and new packages)

sudo apt-get install 3cxpbx
(installs the 3cxpbx)

sudo apt-get install net-tools
(installs older debian commands like ifconfig which has been replaced with ip address in newer versions of debian)

Seguendo questi passaggi arrivo fino all'installazione via web. Tuttavia a un certo punto mi da il problema del database.
Per quanto riguarda la mia frase "ho installato la iso normale e andava benissimo": intendevo che il server non ha problemi rete o di ip mail funzionanti in quanto l'ho testato piu volte con il template normale di WINDOWS UBUTU E DEBIAN e andava alla grande

Cordiali Saluti
 
sinceramente non so dirti...il 3d che riporti è di 4 anni fa e riferito a versioni 3CX (di sicuro) e Debian (non ricordo quando si sia passati a Debian 9) differenti.
La guida per l'installazione manuale è in effetti ancora visibile sul sito, ma non è più indicizzata ufficialmente dal manuale Amministratore perchè si è visto che troppi utenti aprivano ticket su macchine Debian non dedicate.
Di fatto posso solo consigliarti di tentare l'installazione attraverso l'ISO ufficiale e vedere di capire come mai non scarica file che dovrebbero essere scaricabili.
Posso però assicurarti che da ieri quì in Italia sono già state attivate diverse licenze Linux on-premise, quindi la ISO in sè non ha problemi.
Magari qualcuno più esperto di me su Linux può darti altri consigli o magari puoi sentire il supporto KVM
 
Ultima modifica:

Inizia con 3CX – Admin

Forum statistics

Discussioni
44.659
Messaggi
233.416
Membri
78.446
Ultimo Iscritto
Ibra_siby