Restore v18 a V20 - troppe richieste di certificati per lo stesso nome di dominio completo

mbrtech

SOHO User
Registrato
2 Gennaio 2022
Messaggi
1
Buongiorno, ho eseguito update dalla V18 alla V20 Linux manualmente perche tramite grafica falliva continuamente
Ho come prima cosa effettuato update da Debian 10 a Debian 11 e poi Debian 12; durante i processi di update\upgrade anche 3CX si è aggiornato alla versione V20.
Interfaccia grafica web sulla porta 5001 non si avvia e neppure sulla 5015.

Da riga di comando ho eseguiro un reset dell'installazione (sudo /usr/sbin/3CXWizard --cleanup)
A questo punto tramite la porta 5015, ho iniziato il processo di restore , ma mi veniva visualizzato il messaggio "Un processo di installazione è già in esecuzione da un'altra connessione..." ma non cera nessuno che stava accedendo al server oltre al sottoscritto.
Ho ravviato il server piu volte e ho provato piu volte il processo di restore del backup ma avevo sempre lo stesso messaggio "Un processo di installazione è già in esecuzione da un'altra connessione..."

Dopo molti tentaivi, ho il messaggio (allegato) che ho superato "troppe richieste di certificati per lo stesso nome di dominio completo"
Come potrei procedere adesso?
 

Allegati

  • 3CX_error.jpg
    3CX_error.jpg
    59,1 KB · Visite: 1
Ciao,
nel caso la procedura di upgrade automatico da interfaccia non funzioni, quello che devi fare è una nuova installazione da 0 su ISO V20, non forzare l'aggiornamento a riga di comando.
Detto questo, l'errore che vedi proviene da Let's Encrypt ed è fuori dal controllo 3CX: devi per forza aspettare una settimana, prima che lo stesso FQDN sia nuovamente attivabile, mi spiace.
A quel punto prendi il tuo ultimo backup V18 completo e fai una nuova installazione V20 con ripristino del file di backup e sarai operativo
 
  • Like
Reactions: Michele

Inizia con 3CX – Admin

Forum statistics

Discussioni
44.658
Messaggi
233.413
Membri
78.444
Ultimo Iscritto
PCCAdmin