Rinnovo certificato SSL

Salvo18

Forum User
Basic Certified
Registrato
6 Settembre 2021
Messaggi
84
Buongiorno,
mentre stavo controllando un paio di cose sul portal.3cx.com ho visto che mi segnalava un centralino come obsoleto, vado a vedere e mi risultava dal portale con la V16 Update 0 (Build 9).

Mi collego direttamente al centralino per verificare e vedo che in realtà monta la V18 Update 3 (Build 461), ma in basso vedo l'errore:
SSL Certificate renewal has been failed. Error: IpUpdater.FqdnGenerationException: Error creating FQDN: LetsEncrypt failed to validate domain. Please try again in 5 minutes. at PostInstall.CertificateGenerator.ProcessCertificatesDirectory(String directory, Boolean temporaryCertificateGenerated, Int32 regenerateNotSelfSignedCertificatesFrom, Int32 regenerateNotSelfSignedCertificatesTo, CloudServerStatus statuses, Int32 regenerateCertificateExiredInDays, String appBin, UInt16 sipPort, UInt16 tunnelPort, Nullable`1 httpPort, Nullable`1 httpsPort, Boolean isPassiveFailoverMode, Boolean enableDnsHelper) at PostInstall.CertificateGenerator.RenewCertificates(String appBin, String nginxConfigFolder, String configurationPath) A communication error occurred between the DNS Servers and LetsEncrypt. This rarely happens and is usually resolved on the second attempt. 3CX will try again.

Mentre cliccando su Pannello di Controllo > Versione mi restituisce il seguente errore:
Impossibile raggiungere il Server di Attivazione di 3CX. Controlla che il tuo server DNS primario sia in grado di risolvere activate.3cx.com

Confermo che riesco a risolvere activate.3cx.com.

Sapete dirmi come posso risolvere questo problema?

Grazie,
Saluti
 
Ciao,
da quanto dici, pare che il centralino non sia in grado di effettuare una connessione https con l'ERP.
Hai un proxy? qualche filtro Deep Packet Inspection?
 
Ciao,
da quanto dici, pare che il centralino non sia in grado di effettuare una connessione https con l'ERP.
Hai un proxy? qualche filtro Deep Packet Inspection?
Ciao, no confermo che il centralino è completamente libero e non ha niente di mezzo.

Grazie
 
verificalo, perchè l'errore che riporti significa che non sta ricevendo indietro nulla dall'ERP.
Mandami via MP il codice licenza del centralino, così posso verificare se e da quale IP raggiungi l'ERP
 
  • Like
Reactions: Salvo18
verificalo, perchè l'errore che riporti significa che non sta ricevendo indietro nulla dall'ERP.
Mandami via MP il codice licenza del centralino, così posso verificare se e da quale IP raggiungi l'ERP
Ciao, il firewall alla fine non bloccava nulla, ma verificando i DNS del centralino ho visto che come primario aveva l'IP del firewall e secondo Google, ho messo 8.8.8.8 e 8.8.4.4, riavviato e adesso la sezione "Versione" viene caricata correttamente.

Mi rimane però l'errore del rinnovo certificato SSL. C'è modo di forzarlo o lo fa automaticamente?

Grazie ancora,
Ciao!
 
  • Like
Reactions: MarcelloL_3CX
no, lascia il parametro così
 

Inizia con 3CX – Admin

Forum statistics

Discussioni
44.659
Messaggi
233.415
Membri
78.445
Ultimo Iscritto
NordNico