Servizi interrotti Debian 10 a 11

antoliniwalter

Free User
Registrato
9 Settembre 2023
Messaggi
14
Salve,

come da titolo, dopo l'aggiornamento da Debian 10 a 11 e poi avrebbe dovuto fare l'aggiornamento a 12 per la V20 i servizi non funzionano più e da sempre errore nel firewall,

le porte sul router / firewall sono rimaste invariate ma dopo diversi controlli ho scoperto che non apre i servizi su IPv4 ma solo su IPv6 e non capisco il motivo, come si può vedere dallo screen da ssh la porta 5090 è stata aperta esclusivamente su ipv6 e nn su ipv4 dove credo viene effettuato il test; allego anche screen del problema del firewall

Schermata 2023-12-15 alle 20.57.22.png

Schermata 2023-12-15 alle 20.57.55.png



attualmente tutti i servizi sono offline, l'attuale versione è 18.0 (Build 20) su debian 11 in quanto non mi procedere all'aggiornamento V20 su Debian 12

Come risolvo? Devo installare e configurare tutto da zero?

Grazie.
 
Ciao,
V18 su Debian11 non dovrebbe esistere...
Io farei nuova installazione da 0 tramite ISO ufficiale e ripristinando il tuo ultimo backup V18 (debian 10)
 
Ciao,

si la iso era ufficiale senza modifiche eppure non ha funzionato l'aggiornamento, nel log ha dato questo errore:

Ignorato:1 http://repo.3cx.com/debian/1809 bullseye InRelease
Ignorato:2 http://repo.3cx.com/debian-security/1809 bullseye-security InRelease
Scaricamento di:3 http://repo.3cx.com/3cx bullseye-testing InRelease [9.199 B]
Scaricamento di:4 http://repo.3cx.com/3cx bullseye InRelease [9.165 B]
Errore:5 http://repo.3cx.com/debian/1809 bullseye Release
404 Not Found [IP: 104.18.40.127 80]
Errore:6 http://repo.3cx.com/debian-security/1809 bullseye-security Release
404 Not Found [IP: 104.18.40.127 80]
Lettura elenco dei pacchetti...
E: Il repository "http://repo.3cx.com/debian/1809 bullseye Release" non ha un file Release.
E: Il repository "http://repo.3cx.com/debian-security/1809 bullseye-security Release" non ha un file Release.
> Upgrade failed (update)

però aggiornamento da 10 a 11 è andato a buon fine senza errori, poi da 11 a 12 no.


a questo punto visto che ho riconfigurato tutto con il vecchio sistema mi conviene togliere 3cx e non rinnnovare la licenza visto che scade tra 15 giorni circa e valutare tutto ad anno nuovo con una nuova licenza se devo riconfigurare tutto da zero.

Sperando sempre che nei futuri aggiornamenti non faccia lo stesso scherzo.

Grazie.
 
Ho trovato dopo alcune ricerche il problema è lo script di aggiornamento che ha fallito l'installazione; nel suo log ci sono moltissimi errori e lo stesso problema che ho avuto io lo hanno avuto anche 5 utenti sul portale americano, quindi credo sia proprio un problema di 3cx che non riesce a fare aggiornamento da 10 a 12; quindi mi conviene aspettare che sia disponibile la iso direttamente per debian 12 per evitare problemi.
 
la ISO V20 è già disponibile, ma io aspetterei comunque se si tratta di un centralino in produzione:
ad oggi siamo ancora in Release Candidate e l'aggiornamento è consigliato a soli fini di test
 
si infatti era un centralino di produzione, avevo fatto l'aggiornamento dopo l'orario di chiusura per evitare disservizi ma sembra che l'aggiornamento non sia andato a buon fine, quindi ho dovuto riconfigurare tutto con il vecchio sistema che giustamente può gestire solo 1 canale alla volta per numero contro il centralino che ne gestiva 4 canali per numero. A questo punto valuto tutto ad anno nuovo e vedo cosa fare. Grazie.
 

Inizia con 3CX – Admin

Forum statistics

Discussioni
44.658
Messaggi
233.414
Membri
78.444
Ultimo Iscritto
PCCAdmin