Problema Trunk Clouditalia

aferro

New User
Registrato
29 Maggio 2021
Messaggi
23
Ciao a tutti,
è il mio primo post in questo forum e spero di non portare un problema già noto che non sono riuscito a risolvere per la poca esperienza.

Ho un trunk clouditalia appena installato (fornito da irideos) che si collega ma dopo qualche minuto cade restituendo errore 503

Registration at CloudItalia has failed. Destination (sip:83.211.227.21:5060;lr) is not reachable, DNS error resolving FQDN, or service is not available.

Inoltre le chiamate in entrata non funzionano (restituisce errore di chiamata e nemmeno squilla).
Per far funzionare le chiamate in uscita ho dovuto modificare un parametro del trunk sip per utilizzare l'authid di eutelia (questo rispetto al template che 3cx propone), l'errore che dava era questo

[Dev:sip:[email protected]] from L:7.1[Extn:00] failed, cause: Cause: 403 From user does not match authenticated user/

Fortunatamente in questo caso sono riuscito a capire dai log ma per le chiamate in entrata non trovo indicazioni (forse non so dove cercarle)

Dalla macchina debian in cui ho installato il centralino funziona ping e traceroute all'host voip.eutelia.it. Ho fatto il test del firewall e configurato per utlizzare le porte richieste.
Avendo una pool di indirizzi pubblici statici a disposizione ho dedicato al traffico del centralino uno di questi indirizzi specifici.
Non utilizzo lo stun di eutelia

Spero ti poter ricevere un supporto da qualcuno che magari ha fatto già una configurazione 3cx clouditalia :)

Alex
 
Ciao
Se ti può servire questa è la configurazione che ho fatto su di un PBX 3CX e che sta funzionando da circa un anno e mezzo. Ho solo oscurato le ultime tre cifre del numero telefonico.
 

Allegati

  • Cattura.JPG
    Cattura.JPG
    127,5 KB · Visite: 241
Ciao,
Grazie per la risposta. Anche io ho una configurazione uguale qui.
Potresti mandarmi anche un screenshots dei parametri in ingresso e dei parametri in uscita? Magari c'è un errore nel template che forniscono ora
 
Si, ok
non ho regole particolari in ingresso, nella stessa pagina di configurazione del trunk, in fondo puoi mettere la destinazione (vedi ingresso.jpg) che nel mio caso va ad un gruppo di suoneria. Per la regola in uscita, direi che è classica e minimale. (vedi uscita.jpg). Nel mio casio la numerazione NON è di tipo GNR.
 

Allegati

  • Ingresso.JPG
    Ingresso.JPG
    62,8 KB · Visite: 151
  • Uscita.JPG
    Uscita.JPG
    102,3 KB · Visite: 143
Ciao perdonami forse non sono riuscito a spiegarmi.
Intendo uno screenshot di questi parametri (vedi allegati) che trovi sempre nella pagina del primo screenshot che hai postato.

Grazie ancora
 

Allegati

  • parametri_ingresso.png
    parametri_ingresso.png
    45,3 KB · Visite: 119
  • parametri_uscita.png
    parametri_uscita.png
    70,2 KB · Visite: 101
Assolutamente quelli di default. Non ho mai avuto occasione di cambiarli (anche in altri PBX 3CX di cui faccio consulenza) sia con linee Clouditalia, Voipvoice, Messagenet, Mynet, Wolnet, TIM. Di altri fornitori non ho esperienza.
 
Purtroppo a me con i parametri di default non funzionano nemmeno le chiamate in uscita. Mi restituisce l'errore che ho messo nel primo post e sono costretto a cambiare il parametro From: User Part con il valore AuthenticationID per questo ti chiedevo quali parametri hai
 

Allegati

  • parametri_uscita_LI.jpg
    parametri_uscita_LI.jpg
    652,4 KB · Visite: 107
Purtroppo così a distanza senza avere i parametri che ti ha inviato Clouditalia per poter replicare il trunk su di un altro PBX e vedere se ritorna o meno gli stessi errori, o senza poter accedere al PBX in questione, risulta difficile verificare le cause degli errori. Potrei consigliarti di fare una prova prendendo un numero free di Messagenet e inserirlo come trunk sul tuo PBX per vedere se con quel provider è tutto OK o meno. Vediamo anche se qualche altro utente del forum ha un suggerimento da dare.
PS. Potrebbe essere un problema sulle sessioni NAT del router/firewall?
 
Ciao a tutti,
è il mio primo post in questo forum e spero di non portare un problema già noto che non sono riuscito a risolvere per la poca esperienza.

Ho un trunk clouditalia appena installato (fornito da irideos) che si collega ma dopo qualche minuto cade restituendo errore 503

Registration at CloudItalia has failed. Destination (sip:83.211.227.21:5060;lr) is not reachable, DNS error resolving FQDN, or service is not available.

Inoltre le chiamate in entrata non funzionano (restituisce errore di chiamata e nemmeno squilla).
Per far funzionare le chiamate in uscita ho dovuto modificare un parametro del trunk sip per utilizzare l'authid di eutelia (questo rispetto al template che 3cx propone), l'errore che dava era questo

[Dev:sip:[email protected]] from L:7.1[Extn:00] failed, cause: Cause: 403 From user does not match authenticated user/

Fortunatamente in questo caso sono riuscito a capire dai log ma per le chiamate in entrata non trovo indicazioni (forse non so dove cercarle)

Dalla macchina debian in cui ho installato il centralino funziona ping e traceroute all'host voip.eutelia.it. Ho fatto il test del firewall e configurato per utlizzare le porte richieste.
Avendo una pool di indirizzi pubblici statici a disposizione ho dedicato al traffico del centralino uno di questi indirizzi specifici.
Non utilizzo lo stun di eutelia

Spero ti poter ricevere un supporto da qualcuno che magari ha fatto già una configurazione 3cx clouditalia :)

Alex
Ciao aferro, provo ad aiutarti.
La macchina debian è in cloud o nella tua rete locale? Se è in locale ed hai assegnato un ip publico statico alla macchina debian, penso sia completamente esposta ad internet senza protezioni. Ti consiglio di assegnare un ip di lan ed anteporre un firewall correttamente configurato.

Non ho mai avuto bisogno di modificare il template per far funzionare correttamente Clouditalia

Partirei da questo
 
Purtroppo così a distanza senza avere i parametri che ti ha inviato Clouditalia per poter replicare il trunk su di un altro PBX e vedere se ritorna o meno gli stessi errori, o senza poter accedere al PBX in questione, risulta difficile verificare le cause degli errori. Potrei consigliarti di fare una prova prendendo un numero free di Messagenet e inserirlo come trunk sul tuo PBX per vedere se con quel provider è tutto OK o meno. Vediamo anche se qualche altro utente del forum ha un suggerimento da dare.
PS. Potrebbe essere un problema sulle sessioni NAT del router/firewall?
Ciao CBL,
Grazie per i consigli, ho già configurato tutti gli scenari con Messagenet e prima utilizzavo il PBX anche con un gateway Grandstream come trung analogico. Sempre tutto ok.
Ovviamente il test del firewall di 3cx è tutto ok (tranne SIP ALG), ho configurato le regole del firewall per proteggere il server e la rete locale
 
Ciao aferro, provo ad aiutarti.
La macchina debian è in cloud o nella tua rete locale? Se è in locale ed hai assegnato un ip publico statico alla macchina debian, penso sia completamente esposta ad internet senza protezioni. Ti consiglio di assegnare un ip di lan ed anteporre un firewall correttamente configurato.

Non ho mai avuto bisogno di modificare il template per far funzionare correttamente Clouditalia

Partirei da questo
Ciao Giuseppe, grazie per la risposta
La macchina non è esposta completamente, come suggerisci ha un ip locale ed è anteposto un firewall blocca tutto il traffico tranne quello sulle porte necessarie per il corretto funzionamento del pbx con tutte le funzionalità. Test del firewall da 3cx tutto ok

Pare strano anche a me aver dovuto modificare il template per fa funzionare le chiamate in uscita. Una cosa ancora più strana è che in questi giorni di prove per una mattina funzionava tutto, poi nel pomeriggio è tornato a non funzionare correttamente (chiamate in entrata che davano errore di chiamata quando provavo e chiamate in uscita funzionanti).
 
ALG instrada segmenti del tuo ISP e della tua rete interna attraverso un processo noto come traduzione degli indirizzi di rete, Se attivato ALG funge da proxy per riscrivere gli indirizzi di destinazione e pacchetti dati.
Va assolutamente disattivato.

Il link sottostante rimanda ad una spiegazione molto interessante su ALG.

 
ALG instrada segmenti del tuo ISP e della tua rete interna attraverso un processo noto come traduzione degli indirizzi di rete, Se attivato ALG funge da proxy per riscrivere gli indirizzi di destinazione e pacchetti dati.
Va assolutamente disattivato.

Il link sottostante rimanda ad una spiegazione molto interessante su ALG.

Si è disattivato infatti il test non lo rileva
 

Allegati

  • firewall_test.png
    firewall_test.png
    56,9 KB · Visite: 71
Si è disattivato infatti il test non lo rileva

Da quello che vedo nell'immagine firewall_test.png che hai postato, ci sono un paio di problemi.Uno riguarda il test ALG che non viene superato e pertanto occorre trovare il modo di disabilitare la funzionalità SIP ALG sui router e firewall che hai connessi alla linea internet. Il secondo problema secondo me è dovuto ad una mancanza o errato protocopllo (TCP / UDP) di apertura porte verso il centralino. Allego uno screenshot in cui si vede come deve apparire il test del firewall in 3CX
 

Allegati

  • Test_Firewall.jpg
    Test_Firewall.jpg
    91,5 KB · Visite: 40
  • Love
Reactions: aferro
Ciao CBL,
Grazie per il tuo suggerimento. Ho smanettato un po' sul firewall e disabilitato il sip alg. Ora tutto funziona!
Rimane ancora necessario modificare il parametro in uscita come dicevo nei post precedenti (forse perchè il trunk è fornito da irideos clouditalia?). Per quanto riguarda l'impostazione di udp e tcp ho controllato quello richiesto da 3cx e impostato così anche nel firewall.

Grazie per l'aiuto!
 

Allegati

  • firewall_test.png
    firewall_test.png
    64,5 KB · Visite: 27
  • Like
Reactions: CBL
OK dai, sono contento che funzioni:). Per quanto riguarda Irideos/Clouditalia, da quello che mi dici penso, ma è una supposizione, che ultimamente abbiano messo in campo l'autenticazione a 3 vie. Se qualcuno del forum ne sa di più magari ci viene in aiuto. Io ultimamente sto utilizzando molto VoipVoice in quanto la burocrazia e l'assistenza un pò latente di Clouditalia mi ha stressatoo_O, nonostante le loro linee VoIp funzionino bene. Ciao....
 
  • Like
Reactions: aferro
Io ho 2 linee voip sul mio centralino e non è attiva l'autenticazione a 3 vie...

Però, nei giorni scorsi è apparso un aggiornamento del centralino con un nuovo template per le linee clouditalia... hai verificato gli aggiornamenti?
 
Purtroppo a me con i parametri di default non funzionano nemmeno le chiamate in uscita. Mi restituisce l'errore che ho messo nel primo post e sono costretto a cambiare il parametro From: User Part con il valore AuthenticationID per questo ti chiedevo quali parametri hai

E' per caso un numero portato da altro operatore?
 
Si esattamente
devi mettere in "ID di autenticazione (AKA SIP User ID)" e in "Numero principale Trunk" il numero originario di clouditalia e non quello portato
 

Inizia con 3CX – Admin

Forum statistics

Discussioni
44.659
Messaggi
233.416
Membri
78.446
Ultimo Iscritto
Ibra_siby